
American Innovations (AI) is pleased to announce version 1.8 of our Pipeline Compliance System Axis® 
(PCS Axis®) software. This document identifies improvements available in PCS Axis 1.8. For questions or 
additional information, contact PCS Technical Support at pcstechservices@aiworldwide.com. 

Software enhancements and fixes available in PCS Axis 1.8 include those described in the following 
paragraphs:

Telluric Compensation

Telluric Compensation is an optional feature set that provides support for compensating facility and close 
interval inspections with telluric current effects. Stationary data logger (SDL) files used in compensation 
runs are managed in Stationary Survey Maintenance. PCS Axis features enhanced for Telluric Compensation 
include the CPDM and ISM modules, Bridge Import, Field Computer, and Reports/Graphs. 

NOTE: Customers with an existing PCS Axis license who want to use the optional Telluric Compensation 
feature will need a new PCS Axis license. Contact PCS Technical Services for more information. 

System Options

 Default Telluric Threshold: This option only displays when running PCS Axis with a telluric-enabled 
license. The Default Telluric Threshold is in a range of 0.010 volts but can be changed to meet your 
business needs. PCS Axis calculates a baseline average for survey measurements in an SDL data set. 
If any survey measurement in the data set is above or below the baseline average by 0.010 volts, 
this indicates the data set exhibits telluric current effects. 

 Show Detail Inspection Entry Grid: This option controls the display of CPDM Test Point Detail 
mini-grids. When using the optional Telluric Compensation feature, this option is enabled by 
default and cannot be disabled. 

CPDM Test Point Detail mini-grids

Information and Inspection mini-grids display by default when using the optional Telluric Compensation 
feature and cannot be disabled. 

IMPORTANT: To prevent adding duplicate subfacility records in the system, it is important to enter a unique 
subfacility name when adding multiple subfacility records for a test point record in the Test Point 
Information grid. Enter a unique subfacility name in the Name field of the Test Point Detail Information 
mini-grid. Do not use the default name for this field or leave it empty (blank). For more information, refer 
to Linking Multiple Subfacilities to a Parent Test Point Facility in online help or the PCS Axis User and 
Administrator Guide (page 315). 
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Job Service Viewer

 Current Jobs: When a job is in a Waiting or Validated state, clicking the Suspended button 
suspends processing of the selected job. Other jobs in the queue continue to process. Clicking the 
Suspended button for a suspended job resumes processing. 

 Job History / Detail Log: Option labeled ReSend in the Detail Log for an Email Notification 
report allows you to resend the report. 

Field Computer

 Dynamic Picklist User-Defined Fields (UDFs): Can now be included in prompts sent to the 
Allegro Field computer. 

 Mini-grid Fields: ON/OFF subfacility fields in the Test Point Detail Inspection mini-grid can now 
be included in prompts sent to the Allegro Field Computer. The following criteria must first be met 
to include ON/OFF subfacilities in Allegro prompts:

 Subfacilities must be set up as Currently Active in the Test Point Detail Information mini-
grid.

 The parent facility of ON/OFF subfactilities must also be included in prompts sent to the Allegro. 
For example, parent facilities include any of the following PCS fields: AC P/S and AC IRF; 
Casing P/S and Casing IRF; Foreign P/S and Foreign IRF; Insulator P/S and Insulator IRF; 
or Structure P/S and Structure IRF. 

 Field Computer Receive: Pipeline Series and ROW can be applied to close interval (CI) survey 
readings received from the Allegro Field Computer. 

Edit ISM Data / Survey Maintenance

Enhancements in Survey Maintenance allow you to select an existing facility when modifying a range of 
station numbers using Shift and Rubber Band. 

Field and UDF Customizations

Optional property setting labeled Show Time In Milliseconds allows you to set date/time fields with 
millisecond resolution. The property setting applies to date/time fields in Bridge, Field Computer, Reports, 
and data entry grids. 
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PCS Axis v1.7 Release:

Software enhancements and fixes available in PCS Axis 1.7 include those described in the following 
paragraphs:

System Requirements

Microsoft .NET Framework v4.5 is required for PCS Axis v1.7. The PCS Axis installation automatically installs 
.NET Framework v4.5 if it is not installed on the target computer. An active Internet connection is also 
required to complete the installation of .NET Framework v4.5. 

System Options

 Date Carry Forward Enabled Option: Enabling this option allows you to use the last entered 
survey date as the survey date for the next record when working in an Inspection grid or form.

 Show Detail Inspection Entry Grid: Enable this option to display the CPDM Test Point 
Information and Inspection Detail mini-grids.  

Metric Measurements

The system option Activate Metric Mode has been replaced with setting metric measurements at the 
ROW level in Edit ROW Detail. The selection list for Default Location Format now includes the Metric 
Milepost option. This feature is typically used with a pipeline network that spans an area requiring both 
metric and U.S. Customary measurements. 

Negative Milepost Locations

PCS Axis supports facility locations on a pipeline segment with negative milepost numbers. 

Long Name Support

 The names of hierarchy folders as well as the fields labeled ROW Code and ROW Name support 
up to 100 characters. Names longer than 100 characters are shortened by truncating characters to 
the right. 

 The names of routes support up to 100 characters when adding a new route in Define Routes (Data 
Entry > Define Routes > Add). 

Pipeline Series

Enhancements in pipeline Series now calculate the relative milepost based on the previous Series. Series 
Order has been replaced with Previous Series to allow linking of multiple Series in a pipeline Series chain. 

Replication/Reinitializing a Subscription

Subscribers are no longer able to reinitialize a subscription database. This functionality is now available 
only with the publication database. 

Release History
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CPDM Test Point Detail Mini-grids

Support for test points with multiple potential measurements is available using the Test Point Information 
Detail and Test Point Inspection Detail mini-grids. These mini-grids become available for use after enabling 
the system option Show Detail Inspection Entry Grid. The mini-grids function in a similar manner as the 
rectifier mini-grids when linking rectifier anodes and negatives. 

Dynamic Picklist User Defined Field (UDF)

Field and UDF Customizations now support set up of dynamic picklists. A dynamic picklist is a dynamic 
drop-down list with data items that change based on a data item selected in another picklist. This 
dependency uses a cascading parent/child relationship. Selecting a data item in the drop-down list of 
picklist A (parent) determines which data items are available for selection in the drop-down list of picklist B 
(child). 

NOTE: Dynamic Picklist UDFs are not currently supported on the Allegro Field Computer. 

Custom Module Management (CMM)

PCS Axis supports up to ten (10) user defined modules with each module supporting up to ten (10) user 
defined facility types. 

PCS Axis v1.6 Release:

Software enhancements and fixes available in PCS Axis 1.6 include those described in the following 
paragraphs:

PCS Axis Upgrade Installation 

 The upgrade process now copies forward the existing connection settings file set up in Connection 
Manager when upgrading PCS Axis to v1.6 and higher. Manually copying the file to the desktop 
prior to upgrading PCS Axis is no longer required. 

 The upgrade process for v1.5 to v1.6 and higher automatically uninstalls v1.5. Manually uninstalling 
v1.5 is no longer required. Upgrading a version previous to v1.5 does however require uninstalling 
the older version of PCS Axis. 

Field and UDF Customizations

 On/Off Pair UDF: Type of UDF that allows you to set up a custom pair of on/off fields for 
recording inspection readings in a data grid or form. This type of UDF is available for both facility 
and continuous surveys.    

 Summation UDF: Type of UDF that performs an aggregation on one or more fields set up as a 
filter in the Summation UDF. Aggregate functions include Average, Count, Latest, Maximum, 
Minimum, and Sum. This type of UDF is a Permanent Information field available for use in data 
grids, forms, reports, and as a filter in scheduling. 
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Bridge

 Prevalidate, Run, Import, Export: Clicking Prevalidate in the Bridge Definition window 
validates the Bridge definition is set up correctly. The validation process only validates data; it does 
not import or export data. Clicking Run, Import, or Export in the Bridge Definition window 
processes the definition by importing or exporting data based on the setup of Bridge definition. 

 Bridge Import: Check boxes are no longer enabled by default for all “Activate” fields in a Bridge 
import. 

Synchronization / Subscription

A message displays when starting a PCS Axis subscription that identifies the last time the subscription 
synchronized with the publication database. 

CPDM Rectifier Data Grid

The following fields are no longer “read-only” and can be edited: shunt rating, resistance, factor, and 
rectifier rating.

PCS Axis v1.5 Release:

Software enhancements and fixes available in PCS Axis 1.5 include those described in the following 
paragraphs:

PCS Axis Installation File 

The PCS Axis installation file has been updated to include the following features:

 Separate installation files are no longer required to install PCS Axis on a 32-bit and 64-bit computer 
system. A single installation file now installs PCS Axis on either computer system. 

 If the target computer does not have Microsoft® .NET Framework v4.0 installed, the PCS Axis 
installation automatically installs it. This feature requires an active Internet connection to complete 
the installation of .NET Framework v4.0. 

Reindex Stored Procedure

A stored procedure labeled dbo.DefragmentIndexes installs in the PCS Axis database during the v1.5 
upgrade installation. The stored procedure is intended for your company’s Database Administrator (DBA). 
The DBA will use the stored procedure to create a database maintenance job on the database server that 
runs daily or once a week during non-peak hours. The purpose of the stored procedure is to ensure 
optimum system performance by rebuilding indexes in the PCS Axis database that have exceeded the “fill 
factor limit”. For more information, refer to document entitled PCS Axis v1.5 Upgrade Installation. 

Fill Factor Reset Script (optional utility)

A process included in the stored procedure mentioned earlier sets the “fill factor limit” of the PCS Axis 
database on the server. The “fill factor limit” can however be changed if required. Included on the PCS Axis 
v1.5 installation DVD is an optional utility script intended for your company’s DBA. The DBA can use the 
utility script labeled Defrag Fill Factor Reset Post Deployment.SQL to set the “fill factor limit” of the PCS 
Axis database. 
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Data Entry Forms 

PCS Axis supports data entry forms migrated from PCS 7.5 or higher. A forms editor will be available in a 
future software release that allows you to create and edit data entry forms. 

Custom Security Roles (Security Role Management)

A security role is a named set of permissions that determine user access to menus and menu commands in 
PCS Axis. Use the security roles installed with PCS Axis (SysAdmin, User, and Read Only) as a template to 
create custom security roles. Then modify a custom security role based on the requirements of your 
company. You can modify custom security roles to include permissions that grant or deny user access to 
one or more PCS Axis menus and menu commands. 

Bridge Import

Supports the following logical/boolean format variables: yes/no; true/false; and 0/1 (zero/one). 

Reports/Graphs

PCS Inspection Graph: Include facility survey and continuous survey data in the same graph. Use the graph 
report to easily compare survey data in one or more surveys with data from other surveys. 

Email Report Default Time (Email Notification)

When adding a new Email Report, you can either set up the report to use the default “Time” setting (which 
is based on the system Options property setting “Email Default Time”) or enter a different time. The “Time” 
setting determines when an email is sent with the Email Report as an attachment. 

Synchronization

Subscription and Bridge License Message:Activate the Bridge license on the publication database first, and 
then synchronize subscription databases with the publication database. This process activates Bridge for 
operation on subscription databases. A message displays in the Job Service Console to this effect when a 
subscription database needs to activate Bridge via synchronization with the publication database (Tools > 
Job Service Viewer). 

Database Management

 Database Integrity Check:  In the unlikely event data becomes corrupted in the database, use 
Database Integrity Check to identify and resolve instances of data inconsistencies. The process 
performs an audit of the database searching for issues that may prevent PCS Axis from loading or 
performing basic functions. Its purpose is to clean up data issues that may cause problems for 
users, such as orphan records and invalid hierarchy nodes. (File > Database Integrity Check). 

 Reindex Database: The PCS Axis database uses indexes to identify the position of each record in the 
database. As you add and delete records, PCS Axis modifies the appropriate index to reflect new 
record positions. The Reindex Database process restores database efficiency by updating indexes. 

IMPORTANT: Before running Reindex Database, it is recommended that you make a backup of 
the PCS Axis database using Microsoft SQL Server Management Studio (SSMS). For more 
information about SSMS, see the AI document entitled PCS Axis Database Backup and Restore. 
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PCS Axis Help

 Help Window: The Help window is independent of the PCS Axis application. Users can continue to 
work in PCS Axis while viewing a contextual help topic. Contextual help is available by clicking the 
help button in any PCS Axis window. 

 New Help Features: Two versions of PCS Axis Help are available for use. Both contain the same 
information. The default version is used in the PCS Axis application when viewing contextual help 
topics. The alternate version includes support for the following new features and is available for use 
at http://www.pcsaxishelp.aiworldwide.com/AxisHelp/. 

 Discussion System: Support for Disqus is available in the alternate version of PCS Axis Help. 
Disqus is a discussion system that allows users to post feedback, questions, or comments about 
PCS Axis. PCS Technical Services moderates the discussion system providing answers to 
questions and replies to comments. For more information about the discussion system, visit the 
Disqus website at http://help.disqus.com/. 

 Language Translation: The alternate version of help supports language translation using 
Google Translate. To view PCS Axis Help in your language, click the globe icon in the menu bar 
and then select a language. Google Translate supports over 60 different languages. For more 
information about Google Translate, visit https://support.google.com/translate/. 

PCS Axis v1.4.5 Release:

PCS Axis v1.4.5 is intended to optimize system performance by reducing database index fragmentation. 
Index fragmentation may occur in the PCS Axis database after importing large amounts of data using 
Bridge Import, Bullhorn Bridge, or Field Computer. 

Enhancements described in the following list are intended for your company’s Database Administrator 
(DBA). These enhancements should be applied to the PCS Axis database on the server after upgrading to 
v1.4.5. For related information, refer to the document entitled PCS Axis v1.4.5 Upgrade Installation. 

 Fill Factor Reset Script: A utility script labeled Defrag Fill Factor Reset Post Deployment.SQL is 
included on the PCS Axis v1.4.5 installation DVD. Running the script resets the “fill factor limit” on 
the database server to 70 percent. Run the utility script only once and do not include it in a 
database maintenance job on the server. 

 Reindex Stored Procedure: A stored procedure labeled dbo.DefragmentIndexes installs in the 
PCS Axis database during the v1.4.5 upgrade installation. The purpose of the stored procedure is to 
rebuild indexes in the PCS Axis database that have exceeded the “fill factor limit”. To ensure 
optimum system performance, use the stored procedure to create a database maintenance job on 
the database server that runs daily or once a week during non-peak hours. 
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PCS Axis v1.4 Release:

Performance 

Improved performance system-wide with significant improvements in Bridge, Hierarchy Selection, and User 
Management performance.

User Interface

Improved user interface for better usability. 

PCS Axis v1.3 Release:

Connection Manager 

Connection Manager is a utility that installs during the PCS Axis software installation. You can use 
Connection Manager to switch database connections; upgrade a PCS Axis database; and create a new 
database, such as a training database (Start > PCS Axis > Connection Manager). 

Job Service Viewer 

Job Service Viewer provides two functions. One allows you to activate the optional Bridge Import add-on 
while the other provides status information for the following PCS Axis jobs: Bridge Import, Bridge Export, 
Bridge Import/Export, Email Notification, and Field Computer Receive. Status information identifies which 
of these jobs are currently running; those that are waiting in the queue to run; and a history of completed 
jobs (Tools > Job Service Viewer). 

Pipeline Series

Pipeline Series is a feature that allows you to adjust facility numbers on a pipeline when discontinuities 
occur. Discontinuities can occur when an extension is added to the pipeline; the pipeline is re-routed; or 
when a company designates two pipelines as parallel lines. Instead of physically renumbering pipeline 
location numbers on-site, Pipeline Series allows you to shift pipeline numbering in PCS Axis. Each Pipeline 
Series joins together, end-to-end, to make up the entire pipeline. The starting and ending milepost for each 
segment in a Pipeline Series is used by PCS Axis to calculate a Relative Milepost for the entire distance of 
the pipeline (Data Entry > Pipeline Series). 

System Options

 Disable Link Attachments: This system option applies when attaching a document to a record in a 
data grid. When the option is enabled, a document can be embedded but not linked to a record. A 
copy of an embedded document stores in the PCS Axis database and can be accessed by all PCS 
Axis users. A linked document stores on the local computer of the user who linked the document 
and can only be accessed by that user. If your company prefers that users embed documents 
instead of linking to documents, enable this option by clicking the check box. A check mark inside 
the check box indicates the option is enabled (Tools > Options > General).

 Disable Synchronization: This system option allows you to disable the synchronization feature. 
When disabled, the Synchronization menu command is not included in the Tools menu, which 
prevents creating the publication and subscription databases. You can however activate 
Synchronization at anytime if your company decides later to use the feature (Tools > Options > 
Synchronization).
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 Disable Attached Document Preview: This system option applies to documents that have 
previously been attached to a record in a data grid. When the option is enabled, users are unable to 
preview an attached document in the Preview Attached Documents window. When the option is 
disabled, users can open an attached document for editing or viewing purposes if the file type of 
the attached document is associated with a default software program on their computer (Tools > 
Options > General).

Synchronization / Server Authentication Mode

Creating the publisher and subscriber databases now requires that you identify the authentication mode 
used by the server to validate user names and passwords for users connecting to the server. Based on how 
your company has set up the server, the authentication mode is either Windows Authentication or Sql 
Server Authentication. If needed, contact your company's IT department to determine which 
authentication mode to select when creating the PCS Axis publisher and subscriber databases (Tools > 
Synchronization). 

Bridge Import

 License Activation: If your company purchased the optional Bridge Import add-on, activate the 
feature for operation using Job Service Viewer to select the license file provided by American 
Innovations (Tools > Job Service Viewer).

 Pipeline Series: Improvements in Bridge Import allow you to import pipeline series. Bridge Import 
includes a new data item labeled Series that is available for selection in the System Items folder 
when adding data items for mapping. Adding the Series data item provides the following PCS Axis 
fields required for mapping pipeline series: ROW Code, Series Number, Start Milepost, and End 
Milepost. These same fields must also be included in the import transition file you use to import 
data in PCS Axis.

Reports/Graphs

 Data Collection Report: The data collection report is a blank report used by technicians and 
vendors to record survey readings in the field. It is available for selection in all modules except ISM. 
The report uses a columnar report style and includes survey information by module, such as the 
CPDM Data Collection Report. Based on the survey type selected when setting up the report, it 
includes a list of facilities and other optional data, such as previous survey readings (Reports/
Graphs > Module Reports > Data Collection Report).

 Summary Report Layout Theme: A layout theme is a group of named settings saved for later use. 
You can now define a Summary layout theme with report settings that define the table row, 
column, and data fields as well as the aggregate functions (average, sum, count, and percentage) 
used to calculate data fields in a Summary report. Summation fields, field operators, filters, 
drilldown fields, drilldown sorting fields, horizontal and vertical field groupings, as well as paper 
settings can all be saved in a Summary layout theme. A Summary report presents data in a cross tab 
table view. It provides a “big picture” of pipeline and facility data by summarizing and analyzing the 
data. You can control how PCS Axis summarizes the data, for example by sum, average, count, or 
percentage. Using a Summary report can help with analyzing data, making comparisons, and 
detecting patterns in the pipeline system (Reports/Graphs > PCS, Module, or ROW Report > 
Customize > Summary Layouts).
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PCS Axis v1.2 Release:

Synchronization (Tools menu)

PCS Axis Synchronization uses a Microsoft SQL Server publisher/subscriber database model. The 
Publication database is the primary database on a network server or host computer. Each Subscription 
database is a copy of the Publication database. Remote users who do not have access to the Publication 
database can update data in a Subscription database on their local computer. 

Synchronization supports one publisher with multiple subscribers running in a client-server network. 
Synchronizing data between the publisher and subscribers is achieved using merge/pull replication. Merge 
replication is used with the publisher database. Pull replication is used with subscriber databases.

Features of Synchronization include:

 Creating the Publication database (primary PCS Axis database).

 Setting up one or more subscribers (remote users).

 Synchronizing and re-initializing a Subscription database. 

 Switching database connections at a subscriber.

LAN or WAN

Local User with
PCS Axis Application Installed

Local User with
PCS Axis Application Installed

Loc
PCS

Loc
PCS

Network Server or 
Host Computer with
Publication Database

Remote User 
with Subscription Database 

and PCS Axis Application Installed

Remote User 
with Subscription Database 

and PCS Axis Application Installed

Reliable High-Speed Connection
to Publication Database

for Synchronization
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PCS Axis v1.1 Release:

 Indirect Survey Manager (ISM) 
(Modules > Indirect Survey Manager)

ISM includes the following features for working with continuous survey data: 

 Data Entry Grid and Themes 
(Data Entry > Edit ISM Data)

 Survey Folders and Themes 
(Data Entry > Survey Folder Maintenance)

 Reports, Graphs, and Themes 
(Reports/Graphs menu)

ISM reports and graphs include: CIS Reports (Close Interval Survey Reports); AC CIS Reports 
(AC Close Interval Survey Reports); DCVG Reports (DC Voltage Gradient Reports); ACVG Reports 
(AC Voltage Gradient Reports); ACCA Reports (AC Current Attenuation Reports); Soil Resistivity 
Reports; and Pearson Reports. 

 User Defined Fields 
(Tools > Field and UDF Customizations > Continuous Surveys)

 Field Computer and Themes 
(Field Computer > Send, Receive)

 Themes Management 
(Tools > Themes Management; Tools > Facility Type Themes)

 Custom Module Management (CMM)
(Modules > Custom Module Management)

CMM is an optional add-on available for purchase. CMM allows users to work with facility types not 
included with PCS Axis by creating a user defined module with up to six user defined facility types. 
CMM includes the following features:

 Data Entry Grid and Themes 
(Data Entry > Edit <module> Data)

 Survey Folders and Themes 
(Data Entry > Survey Folder Maintenance)

 Schedules, Routes, and Themes 
(Data Entry > Define Schedules, Edit Schedule Settings and Data Entry > Define Routes)

 Reports, Graphs, and Themes 
(Reports/Graphs menu)

 User Defined Fields 
(Tools > Field and UDF Customizations)

 Themes Management 
(Tools > Themes Management and Tools > Facility Type Themes)
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 Email Notification
(Tools > Email Notification) 

Email Notification is a feature for sending columnar reports as an attachment in an email at a 
regularly scheduled time to recipients. Recipients include PCS Axis users as well as non-PCS Axis 
users. 

 Field Computer
(Field Computer menu)

Send and receive continuous survey data for use in the ISM module. 
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If you have a suggestion, question, feature request, or a bug to report-your feedback would be 
appreciated. Also if you have a training need for your organization or would like to know more about 
upcoming PCS Axis training classes, use any of the following contact information to reach PCS Technical 
Services:

Support E-mail:  pcstechservices@aiworldwide.com
Support Telephone:  1-800-229-3404 (select 1, then press 2)
American Innovations:  http://www.aiworldwide.com

Product Support and Training
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